Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Facebook Sign In with Google Sign In with Twitter

Errors on startup

chtguchtgu Member
edited December 2014 in ScoreCloud Studio
I constantly run into this error.

The assertion (= MIDI::INPUT-SAMPLE-RATE MIDI::OUTPUT-SAMPLE-RATE) failed.

When I go into audio option, nothing is selected. When I go through the drop-downs and select audio drivers for midi, input, and output, right after closing the menu it will tell me that "An error occured" with "ignore error/quit." If I ignore, pressing play will loop me through the same errors again.

How can I fix this?

Comments

  • Anyone?
  • JohanRJohanR Administrator
    Hi!

    This is strange! Could you please send us your log files, either attached here or to support@scorecloud.com?

    To find the log files (ScoreCloud.log and faudio.log) on Windows:
    Open the "Run"-window by pressing the windows-key+R and then type %APPDATA%/ScoreCloud

    To find the log files (ScoreCloud.log and faudio.log) on Mac OS X:
    Press cmd-shift-g ( ⌘-⇧-G) in Finder and paste ~/Library/Containers/com.doremir.scorecloud/Data/Library/Logs

    Regards
    / JohanR
    ScoreCloud Staff and Mandolinist
  • I've just downloaded ScoreCloud and am very excited about it; getting the same error the user above cites but I think I know why: I don't yet have a mic plugged into my PC. Am I correct in thinking that when the mic arrives (on order right now!), the program will allow me to turn my vocalizing into musical scores?
  • ErikRErikR Administrator
    Sorry for this late answer, I missed this question.

    The error message is terrible, and we will fix it to the next version – but in essence, it means that you have different sample-rate settings for your audio input and output, which is currently not supported in ScoreCloud Studio.

    You can fix this quite easily by setting matching sample rates.

    (I assume that you are on Mac OS X? This error message is most common there)

    1) Open the Audio MIDI Setup utility application (found in Application/Utilities)
    2) Open the Audio Window, if it is not already open, from the Window menu
    3) In the device list to the left, select your microphone
    4) Choose a sample rate for the microphone in the "Format" box to the right (e.g. 44100,0 Hz)
    5) Now select your output device in the device list
    6) Choose the same sample rate for this device

    Now you should be able to get sound in ScoreCloud Studio! You will have to restart audio in ScoreCloud Studio (from the Preferences window), or restart the application itself.
  • ErikRErikR Administrator
    There have been at least one report that in some cases you will need to change sample rate of ALL audio devices, not just the ones you use in ScoreCloud. That shouldn't be needed, but if you get the same error again, that would be the next thing to try!
Sign In or Register to comment.